ผู้เขียน หัวข้อ: วิธีป้องกัน Mikrotik การถูกโดนโจมตี เจาะ แฮ๊ก ผ่านพอร์ต FTP และ SSH  (อ่าน 22148 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

chan

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 3

วิธีป้องกัน Mikrotik การถูกโดนโจมตี เจาะ แฮ๊ก ผ่านพอร์ต FTP และ SSH




สวัสดีครับพี่ยอด และ สาวก Mikrotik

พอดีว่าตั้งแต่ใช้เจ้า Mikrotik มา ถึงแม้ว่าจะตั้ง User / Password อย่างแข็งแรงเท่าที่จะทำได้แล้วก็ตาม.. แต่เมื่อ เปิดหน้า Terminal ทิ้งไว้จะเห็นได้ว่า เหมือนกับมีคนพยายามลอง Hack เข้ามาหาเราแปลกๆ อยู่ตลอดทั้งวันเลยครับ ดังรูป



ผมเลยลองหาวิธี จากอินเทอเนท และ เว็บบอร์ดต่างประเทศดู จนได้คำตอบมา และ นำมาแบ่งปันให้ครับ

ตย.โค๊ด ที่ 1. ป้องกันพอร์ต FTP ของเราด้วยการ อนุญาต ให้ล๊อกอินผิดผ่าน FTP ได้แค่ 10 ครั้งต่อ 1นาที - ใช้โค๊ดตามนี้ครับ

/ip firewall filter

add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \
comment="drop ftp brute forcers"

add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" \
address-list=ftp_blacklist address-list-timeout=3h


ด้วยโค๊ดด้านบนนี้ จะทำการ ดีด IP ที่ล๊อกอินผิด 10 ครั้งภายใน 1นาที เข้าไปอยู่ใน Blacklist โดยอัตโนมัติครับ

ตย. โค๊ดที่ 2. ป้องกันพอร์ต SSH ของเราด้วยการ บล๊อก IP ที่พยายามล๊อกอินผิดซ้ำๆ เป็นเวลา 10วัน (ปรับได้ตามเห็นสมควรของแต่ล่ะท่านครับ)

/ip firewall filter

add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
comment="drop ssh brute forcers" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
address-list-timeout=10d comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no


โดยทั้ง 2 ตัวอย่างนี้ สามารถ ปรับใช้ด้วยกันได้ครับ เช่น อยากบล๊อก ทั้ง FTP และ SSH ด้วยวิธีที่ 2 เหมือนกัน ก็เพียงเปลี่ยน พวก dst-prt, comment, เป็นต้น ให้ต่างกัน

ขอให้มีความสุข และรู้สึกปลอดภัยในการใช้ Mikrotik นะครับ ... หวังว่าคงเป็นประโยชน์ไม่มากก็น้อยนะครับ  ;) ;) ;)
« แก้ไขครั้งสุดท้าย: วันที่ 24 กันยายน 2013, 08:24:41 โดย yod »

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1846
    • Sysnet Center
http://www.sysnetcenter.com/images/fromboard/image-BFBB_50D29347.jpg[/img]

ผมเลยลองหาวิธี จากอินเทอเนท และ เว็บบอร์ดต่างประเทศดู จนได้คำตอบมา และ นำมาแบ่งปันให้ครับ

ตย.โค๊ด ที่ 1. ป้องกันพอร์ต FTP ของเราด้วยการ อนุญาต ให้ล๊อกอินผิดผ่าน FTP ได้แค่ 10 ครั้งต่อ 1นาที - ใช้โค๊ดตามนี้ครับ

/ip firewall filter

add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop \
comment="drop ftp brute forcers"

add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect" \
address-list=ftp_blacklist address-list-timeout=3h


ด้วยโค๊ดด้านบนนี้ จะทำการ ดีด IP ที่ล๊อกอินผิด 10 ครั้งภายใน 1นาที เข้าไปอยู่ใน Blacklist โดยอัตโนมัติครับ

ตย. โค๊ดที่ 2. ป้องกันพอร์ต SSH ของเราด้วยการ บล๊อก IP ที่พยายามล๊อกอินผิดซ้ำๆ เป็นเวลา 10วัน (ปรับได้ตามเห็นสมควรของแต่ล่ะท่านครับ)

/ip firewall filter

add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop \
comment="drop ssh brute forcers" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist \
address-list-timeout=10d comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new \
src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3 \
address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1 \
action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list \
address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no


โดยทั้ง 2 ตัวอย่างนี้ สามารถ ปรับใช้ด้วยกันได้ครับ เช่น อยากบล๊อก ทั้ง FTP และ SSH ด้วยวิธีที่ 2 เหมือนกัน ก็เพียงเปลี่ยน พวก dst-prt, comment, เป็นต้น ให้ต่างกัน

ขอให้มีความสุข และรู้สึกปลอดภัยในการใช้ Mikrotik นะครับ ... หวังว่าคงเป็นประโยชน์ไม่มากก็น้อยนะครับ  ;) ;) ;)


ขอบคุณมากๆเลยครับ  ;D

ratth

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 1
ขอบคุณครับ กำลังเจอบ่อยๆเลยช่วงนี้

nanapooy

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 6
 :D ;D thank you มมากๆครับ

yukyai

  • Newbie
  • *
  • กระทู้: 3
    • อีเมล์
มือใหม่ ต้องรีบเก็บๆ  ขอบคุณมากๆครับ  ;D

llwswss

  • Ubiquiti Member
  • Newbie
  • *****
  • กระทู้: 14
Re: วิธีป้องกัน Mikrotik การถูกโดนโจมตี เจาะ แฮ๊ก ผ่านพอร์ต FTP และ SSH
« ตอบกลับ #5 เมื่อ: วันที่ 10 มิถุนายน 2014, 06:42:52 »
พี่ยอดนี้สุดยอดเหมือนชือเลยครับ

llwswss

  • Ubiquiti Member
  • Newbie
  • *****
  • กระทู้: 14
Re: วิธีป้องกัน Mikrotik การถูกโดนโจมตี เจาะ แฮ๊ก ผ่านพอร์ต FTP และ SSH
« ตอบกลับ #6 เมื่อ: วันที่ 13 มิถุนายน 2014, 12:13:23 »
ขอบคุณมากเลยครับเราใช้รวมกันได้เลยใช่ปะครับ

amprin

  • Newbie
  • *
  • กระทู้: 1
    • อีเมล์
ขอบคุณครับ


Share via facebook

xx
เซ็ต mikrotik hotspot wifi ไม่ให้ user ทั่วไปเข้าถึง อุปกร เราเตอร์ mikrotik

เริ่มโดย oanzaai เมื่อ อุปกรณ์ Mikrotik Router

2 ตอบ
4270 อ่าน
กระทู้ล่าสุด วันที่ 6 พฤษภาคม 2015, 17:20:17
โดย oanzaai
xx
mikrotik pppoe server ใช้ linksys ปรับเป็น pppoe แล้วใส่ ยูส รหัส ที่ได้จาก mikrotik ได้ไมครับ

เริ่มโดย titipan เมื่อ อุปกรณ์ Mikrotik Router

2 ตอบ
2320 อ่าน
กระทู้ล่าสุด วันที่ 21 พฤษภาคม 2013, 11:25:07
โดย titipan
xx
สิทธิการเข้าใช้งานหัวข้อ Mikrotik

เริ่มโดย venomoth เมื่อ สอบถามข้อมูลทั่วๆไป ข่าวสารจากร้าน Sysnet Center

3 ตอบ
3331 อ่าน
กระทู้ล่าสุด วันที่ 27 กุมภาพันธ์ 2013, 12:20:04
โดย yod
xx
กังวลใจการปิด mikrotik

เริ่มโดย Bonn121 เมื่อ อุปกรณ์ Mikrotik Router

7 ตอบ
1482 อ่าน
กระทู้ล่าสุด วันที่ 26 ตุลาคม 2013, 16:55:57
โดย yod
xx
ip cloud ของ mikrotik

เริ่มโดย yuttapong เมื่อ อุปกรณ์ Mikrotik Router

4 ตอบ
1299 อ่าน
กระทู้ล่าสุด วันที่ 24 พฤศจิกายน 2014, 16:18:01
โดย yuttapong
 


Users found this pages searching for: