ผู้เขียน หัวข้อ: Mikrotik การทำ Proxy เก็บ Internet cache ลง USB Flash Drive  (อ่าน 24632 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1760
    • Sysnet Center
Mikrotik การทำ Proxy เก็บ Internet cache ลง USB Flash Drive
« เมื่อ: วันที่ 5 มกราคม 2013, 13:32:56 »

ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive






สวัสดีครับ


ในอุปกรณ์ Mikrotik Routerboard จะมี function web proxy cache จะช่วยเรื่องการใช้งาน internet ให้เร็วขึ้นในกรณีเข้า web site เดิมๆ บ่อยๆ เช่นในสำนักงาน หรือ ที่ๆมี User ใช้งานกันเยอะๆ โดยในตัวอย่างการทดสอบนี้ จะเก็บ cache ไว้ใน usb flash drive ครับ


ผมใช้ usb flash drive ขนาด 8GB ของ sandisk เดี๋ยวนี้ราคาถูกมากๆ ต่อเข้ากับ Mikrotik รุ่น RB751G ครับ





1. Login เข้า Winbox ไปที่ Menu System --> Store --> Disks จะมีรายการ usb1 ขึ้นมา ให้ Click เลือกและ Format Drive เลย (ข้อมูลใน Flash drive จะหายหมดนะครับ)




2. ใช้เวลา Format ค่อนข้างนานเหมือนกัน รอจนกว่าจะขึ้น Status ready




3. ไปที่ Tab Stores --> Click [Copy] เลือก
Store: web-proxy1
To: usb1
Click เครื่องหมายถูกที่ Active
Click [Copy]




4.Copy web proxy เรียบร้อย Status จะต้องเป็น active




5. เข้าที่ Menu IP --> Web proxy แล้ว Config ตามรูปได้เลยครับ
Max.Cache Size จะเป็นความจุของ flash drive ครับ ผมเลือกแค่ 6GB (6 x 1024 x 1024 จะได้หน่วยเป็น KB คือ 6291456 KiB)




6. ที่นี้ก็สร้าง Transparent proxy ครับ

เข้าที่ Menu IP --> Firewall --> NAT
กำหนดตามรูปได้เลยครับ
Tab General
Chain: dstnat
Protocol: 6(tcp)
Dst.Port: 80



Tab Action
Action: redirect
To Ports: 8080
Click [OK]



ลากขึ้นมาให้อยู่ด้านบน






ทดสอบ

1. ผมลอง Download file ขนาด 10MB




จะได้ความเร็วประมาณ 11.1mbps (หน่วย MB กับ Mb จะต่างกันเยอะนะครับ หน่วย MBps กับ Mbps ต่างกันยังไง ความเร็ว ISP Speed ทำไมไม่ตรงกับที่ Download)




2. ทีนี้ลอง Download ใหม่อีกรอบ ไฟล์ที่ download ครั้งแรก ถูกเก็บไว้ใน cache proxy เรียบร้อยแล้ว




แท่งแดงๆที่โผล่ขึ้นมาครับ คือความเร็วในการ Download ไฟล์รอบนี้ ความเร็วประมาณ 87mbps  :o :o :o




3. ทีนี้เข้าดูที่ Web proxy statu ครับ จะแสดงจำนวน Cache Used คือความจุที่ใช้ไป




ถ้า Click ที่ Cache Contents จะแสดงรายการไฟล์ที่ถูกเก็บอยู่ใน Cache จะมีไฟล์ที่ download เมื้อกี้ด้วยครับ ถ้าต้องการลบออกก็ Click [Clear Cache]





ทีนี้ถ้าต้องการใช้งาน ในกรณีจำกัดความเร็วการใช้งาน Internet แต่เมื่อมีการเรียกจาก Cache ไม่ต้องจำกัดความเร็ว


เช่นจำกัดความเร็วให้แต่ละ Client เป็น 1Mbps แต่ ถ้าเป็น website ที่ถูกเก็บไว้ใน cache เรียบร้อยแล้ว จะไม่มีการจำกัดความเร็ว (Unlimit)

Copy code ด้านล่างไปแปะที่ New terminal ใน Winbox ได้เลยครับ

โค๊ด: [Select]
/ip firewall mangle
add action=mark-packet chain=output comment="cache" disabled=no dscp=4 \
new-packet-mark=cache-hits passthrough=no

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
max-limit=0 name="Unlimited Speed cache" packet-mark=cache-hits \
parent=global-out priority=8 queue=default


หลังจาก run script แล้ว ให้ตรวจสอบที่ Menu ต่างๆ ตามรูป











กำหนด Bandwidth ที่ Menu Queue โดยผมกำหนดให้ได้ค่า Rx/Tx สูงสุด 1M/1M




ทดสอบ Download อีกรอบ (อย่าลืม Clear cache ก่อนนะครับ) ได้เต็มที่ 1.09 mbps ถือว่าใกล้เคียงกับที่ตั้งค่าไว้ใน QOS  :D




ลอง Download อีกครั้ง จะเป็นการดึงไฟล์มาจาก Cache ได้ความเร็วเต็มๆ  ;D








เรียบร้อยครับ
« แก้ไขครั้งสุดท้าย: วันที่ 8 พฤษภาคม 2017, 13:16:45 โดย yod »

lithium

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 28
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #1 เมื่อ: วันที่ 24 ตุลาคม 2013, 11:04:29 »
450g  สามารถมั้ยครับพี่
เห็นช่องเสียบ microsd

Mr.Zenith

  • VIP
  • Full Member
  • *****
  • กระทู้: 172
  • Central Radius Expert
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #2 เมื่อ: วันที่ 24 ตุลาคม 2013, 13:08:39 »
เก็บ cache web proxy ลง MicroSD ก็ได้ครับ แต่ระวังเรื่องการอ่าน-เขียนช้า จะทำให้ระบบโดยรวมหน่วงไปหมด

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1760
    • Sysnet Center
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #3 เมื่อ: วันที่ 24 ตุลาคม 2013, 13:24:28 »
450g  สามารถมั้ยครับพี่
เห็นช่องเสียบ microsd
เก็บ cache web proxy ลง MicroSD ก็ได้ครับ แต่ระวังเรื่องการอ่าน-เขียนช้า จะทำให้ระบบโดยรวมหน่วงไปหมด
[/quote]

หน่วงค่อนข้างเยอะเลยละครับ  :D :D

ต้องดู speed ในการ read/write ของ storage ที่นำมาเก็บ cache ด้วยครับ กลายเป็นช้ากว่าเดิมอีก  ;D ;D

lithium

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 28
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #4 เมื่อ: วันที่ 24 ตุลาคม 2013, 15:29:04 »
16gb class10   พอไหวมั้ยครับ

nhoke

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 6
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #5 เมื่อ: วันที่ 19 กุมภาพันธ์ 2014, 03:38:06 »
ผมซื้อ Micro-SD ของ Sandisk 32GB Class 10 มา
ใช้กับรุ่น 450G ก็ไม่มีอาการหน่วงแต่อย่างใดนะครับ

nhoke

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 6
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #6 เมื่อ: วันที่ 19 กุมภาพันธ์ 2014, 03:43:22 »
คุณ Yod ครับ

พอดีผมใช้ Hotspot ร่วมกับ Userman อยู่ครับ ไม่ ทราบว่ามีวิธี Set ให้ user ใน Userman
ไปเรียกข้อมูลจาก Cache โดยไม่ถูกจำกัด Speed จากใน User Profile ของ Userman:81 ไหมครับ

ขอบคุณมากๆล่วงหน้าครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1760
    • Sysnet Center
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #7 เมื่อ: วันที่ 19 กุมภาพันธ์ 2014, 13:11:46 »

ยังไม่เคยทดสอบนะครับ

แต่ใน menu firewall ลองลาก action redirect ที่เข้า proxy มาไว้บนสุดดูครับ

ksis

  • Newbie
  • *
  • กระทู้: 1
    • อีเมล์
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #8 เมื่อ: วันที่ 13 มิถุนายน 2014, 10:01:58 »
พี่ yod ครับ....ผมลองทำกับ rb2011Uias usbsandisk16G มันไม่cacheไฟล์ใหญ่ๆทั้งๆที่ตั้งให้สามารถcacheไฟล์ได้สูงสุดแล้วตามขนาดusb
แล้วตรงhit sent to client ก็ไม่ส่งเลย ไม่รู้ต้องทำยังงัย

beetdragon

  • Newbie
  • *
  • กระทู้: 1
Re: ทดสอบ Mikrotik Web-Proxy เก็บ Internet cache ลง USB Flash Drive
« ตอบกลับ #9 เมื่อ: วันที่ 28 ตุลาคม 2014, 01:29:14 »

ใช่ Sandisk 32GB  ตัวไหนหรอคับ ULTRA หรือ extreme อะคับ พอดีกลัวซื้อผิดแล้วมันใช้ไม่ได้อะคับ


Share via facebook

xx
เรียนคุณ ยอดครับเรื่อง Proxy Cache นอกครับ

เริ่มโดย tpfresh เมื่อ อุปกรณ์ Mikrotik Router

9 ตอบ
415 อ่าน
กระทู้ล่าสุด วันที่ 18 พฤศจิกายน 2013, 13:58:59
โดย yod
xx
รบกวนสอบถาม เก็บ log web proxy แล้วเข้าเน็ตไม่ได้

เริ่มโดย bie01 เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
833 อ่าน
กระทู้ล่าสุด วันที่ 24 มีนาคม 2017, 11:29:29
โดย bie01
xx
เก็บ Log การใช้งาน Internet จาก Mikrotik Router

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

3 ตอบ
42536 อ่าน
กระทู้ล่าสุด วันที่ 11 เมษายน 2016, 11:25:06
โดย yod
xx
เก็บ Log การใช้งาน Internet จาก Mikrotik Router ด้วย Zyxel NSA210

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

3 ตอบ
9254 อ่าน
กระทู้ล่าสุด วันที่ 5 มีนาคม 2015, 11:53:35
โดย Mr.Zenith
xx
เก็บ Log การใช้งาน Internet ตาม พรบ.คอมฯ

เริ่มโดย yod เมื่อ iBSG : The Wi-Fi Hotspot Gateway with Cloud Management System

0 ตอบ
2886 อ่าน
กระทู้ล่าสุด วันที่ 3 พฤศจิกายน 2015, 13:20:35
โดย yod
 


Users found this pages searching for: