ผู้เขียน หัวข้อ: การ Block Website, File Download และ คำต้องห้ามใน URL  (อ่าน 11481 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

yod

  • บุคคลทั่วไป
การ Block Website, File Download และ คำต้องห้ามใน URL
« เมื่อ: วันที่ 9 พฤษภาคม 2011, 00:49:42 »

การ Block Website, File Download และ คำต้องห้ามใน URL



สวัสดีครับ หัวข้อนี้จะเป็นการใช้ Mikrotik Block Website, ไฟล์ที่ Download นามสกุลต่างๆ รวมถึงการ Block คำที่ต้องการในชื่อ website ได้ด้วยครับ


1. Login เข้า Winbox เข้า Menu New Terminal

Copy Code ด้านล่างแล้ว Paste ใน Terminal แล้ว กด Enter



/ip proxy
set enabled=yes
set src-address=0.0.0.0
set port=8080
set parent-proxy=0.0.0.0
set parent-proxy-port=0
set cache-administrator="webmaster"
set max-cache-size=none
set cache-on-disk=no
set max-client-connections=600
set max-server-connections=600
set max-fresh-time=3d
set always-from-cache=no
set cache-hit-dscp=4
set serialize-connections=no




2. แก้ไข IP Address ให้ตรงกับ IP ขา Lan ของ RouterBoard ใน Code ด้านล่าง Copy Code ด้านล่างแล้ว Paste ใน Terminal แล้ว กด Enter

#Update 09/01/2013
/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.1 to-ports=8080


แก้ไขเป็น

/ip firewall nat add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp to-ports=8080

และ


3. แก้ไข Interface ที่ต่อเข้ากับ Internet (Wan) จากตัวอย่าง Interface ที่ออก Internet ของผมเป็น pppoe-out1 หรือถ้าในกรณีที่ Interface ขาออกเป็น DHCP Client ที่ ether1 ก็ให้ใส่เป็น ether1 ครับ

/ip firewall filter
add chain=input in-interface=pppoe-out1 src-address=0.0.0.0/0  protocol=tcp dst-port=8080 action=drop


/ip firewall filter
add action=drop chain=input comment="Block Other Proxy" disabled=no dst-port=8080 in-interface=pppoe-out1 protocol=tcp  src-address=0.0.0.0/0


4. ใส่ชื่อ Website ที่ต้องการ Block ได้เลยครับ จากตัวอย่างผมจะ Block web google.com  :P

/ip proxy access
add dst-host=www.google.com action=deny




ดูข้อมูลที่เรา Block ไว้ได้ที่ Menu IP --> Web Proxy




เรียบร้อยครับ จะเข้า Web ไม่ได้เลย  :o




ทีนี้ในกรณีที่เราต้องการ Block ในกรณีที่มีคำต้องห้ามในชื่อ Web  :'( :'(

5. เข้า Menu IP --> Web Proxy --> เข้าที่ Tab Access --> Click [ + ]
Dst. Host ให้ใส่ :keyword  (keyword คือคำที่ต้องการให้ BLock ครับ ดูจากรูปประกอบ)
Action: deny



จากนั้น Click [OK]

ลองเข้า web ที่มีคำต้องห้ามอยู่ใน URL




6. ทีนี้ถ้าต้องการ Block File ไม่ให้ Download

จากตัวอย่าง Code ด้านล่างจะเป็นการ Block File exe, mp3, zip และ rar

ให้ Copy ใส่ Script ใน New Terminal ได้เลยครับ

/ip proxy access
add path=*.exe action=deny
add path=*.mp3 action=deny
add path=*.zip action=deny
add path=*.rar action=deny.



เรียบร้อยครับ  ;D ;D

ลองทดสอบกับ Facebook แล้ว ไม่ Work นะครับ ไม่รู้ว่าเพราะอะไรครับ
« แก้ไขครั้งสุดท้าย: วันที่ 19 มิถุนายน 2014, 16:23:03 โดย yod »

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1850
    • Sysnet Center
Re: การ Block Website, File Download และ คำต้องห้ามใน URL
« ตอบกลับ #1 เมื่อ: วันที่ 12 ธันวาคม 2012, 12:18:05 »
เพิ่มเติมครับ พอดีมีลูกค้าถามมาต้องการ block เป็นเวลา

Block ตั้งแต่เวลา 7.30 - 16.30 ถ้าต้องการเวลาอื่นแก้ไขได้เลยครับ

แปะที่ new terminal ครับ

โค๊ด: [Select]
system script add name=unblock_web policy=read,write source="/ip proxy set enable=no"
system script add name=block_web policy=read,write source="/ip proxy set enable=yes"

system scheduler add name=start-unblock start-date=nov/06/2012 start-time=16:30:00 interval=1d on-event=unblock_web policy=read,write
system scheduler add name=start-block start-date=nov/06/2012 start-time=07:30:00 interval=1d on-event=block_web policy=read,write

cartoonfish

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 2
Re: การ Block Website, File Download และ คำต้องห้ามใน URL
« ตอบกลับ #2 เมื่อ: วันที่ 17 ธันวาคม 2012, 15:31:34 »
แล้วถ้าต้องการ เปิดใช้งานได้เฉพาะ จ-ศ เวลา9.00-16.00 ให้ออกเนทได้บ้างชนิดแต่เสาอาทิตย์ ให้ใช้ได้เต็มรุปแบบจะกำหนดสคิปยังไงครับให้เราเตอร์รู้จัก จ-ศ และเสาอาทิตย์

chan

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 3
Re: การ Block Website, File Download และ คำต้องห้ามใน URL
« ตอบกลับ #3 เมื่อ: วันที่ 18 ธันวาคม 2012, 17:04:20 »
system script add name=unblock_web policy=read,write source="/ip proxy set enable=no"
system script add name=block_web policy=read,write source="/ip proxy set enable=yes"

system scheduler add name=start-unblock start-date=nov/06/2012 start-time=16:30:00 interval=1d on-event=unblock_web policy=read,write
system scheduler add name=start-block start-date=nov/06/2012 start-time=07:30:00 interval=1d on-event=block_web policy=read,write[/code]

สวัสดีครับพี่ยอด และชาว Mikrotik

พอดีผมลองทำตามพี่ยอดว่าแล้วครับแต่ดูเหมือนว่า ในส่วนของ...

โค๊ด: [Select]
system script add name=unblock_web policy=read,write source="/ip proxy set enable=no"
system script add name=block_web policy=read,write source="/ip proxy set enable=yes"

เจ้าตัว Mikrotik ก็ enable กับ disable ปกติดีครับ แต่เหมือนว่าจะมีปัญหาอยู่ว่า ก็ยังบล๊อกเว็บไม่ได้อยู่ดี ผมก็เลยลองแก้ในส่วนของ Source ให้เหมือนกับของ บล๊อก Facebook จากคำแนะนำของพี่ยอดดู ปรากฏว่าใช้ได้ครับ โดยการ...

1. ทำคอมเม้นให้กับ เว็บที่เราบล๊อกแต่ละตัว เช่นของผม มี www.youtube.com กับ www.pantip.com ใช้ comment = access-drop ดังรูปตัวอย่าง




2. จากนั้นแก้ Source ใน Scipts List ครับ ด้วยโค๊ดนี้ หรือ ดังรูปตัวอย่าง

2.1 สำหรับ unblock

โค๊ด: [Select]
/ip proxy access disable [find comment=access-drop]



2.2 สำหรับ block

โค๊ด: [Select]
/ip proxy access enable [find comment=access-drop]



3. เมื่อลอง รัน Script unblock ก็จะเห็น ใน /ip proxy access เป็น สีเทาๆ ดังรูปครับ




หวังว่าคงจะเป็นประโยชนไม่มากก็น้อยน่ะครับ  ;)
« แก้ไขครั้งสุดท้าย: วันที่ 25 ธันวาคม 2012, 14:14:13 โดย yod »

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1850
    • Sysnet Center
Re: การ Block Website, File Download และ คำต้องห้ามใน URL
« ตอบกลับ #4 เมื่อ: วันที่ 19 ธันวาคม 2012, 14:50:56 »
ขอบคุณมากๆเลยครับ  ;D ;D

suchat88

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 3
    • อีเมล์
Re: การ Block Website, File Download และ คำต้องห้ามใน URL
« ตอบกลับ #5 เมื่อ: วันที่ 21 กรกฎาคม 2013, 16:52:41 »
เป็นความรู้ที่ผมอยากทำมากก่อนเปิด Hotspot wifi ไม่อยากให้เด็กที่บ้านเข้าเว็บเหล่านี้ เว็บโป้ ขอบคุณครับมีประโยชน์มาก

yukyai

  • Newbie
  • *
  • กระทู้: 3
    • อีเมล์
Re: การ Block Website, File Download และ คำต้องห้ามใน URL
« ตอบกลับ #6 เมื่อ: วันที่ 2 ตุลาคม 2013, 17:50:09 »
มือใหม่!ได้ความรู้อีกแล้ว ขอบคุณครับ   ;D


Share via facebook

xx
การ Block Download File ด้วยอุปกรณ์ QNO Firewall Router

เริ่มโดย yod เมื่อ อุปกรณ์ QNO (คิวโน่)

1 ตอบ
9794 อ่าน
กระทู้ล่าสุด วันที่ 24 กันยายน 2014, 15:35:00
โดย Openerbitbig
xx
อยากทราบวิธีการ Block download กับ Bit รุ่น RB951Ui-2nD-TH

เริ่มโดย buskubsa เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
2103 อ่าน
กระทู้ล่าสุด วันที่ 10 กุมภาพันธ์ 2016, 15:40:11
โดย buskubsa
xx
การ Config Mikrotik Router ให้เครื่องลูกข่ายเข้าได้บาง Website

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

2 ตอบ
12741 อ่าน
กระทู้ล่าสุด วันที่ 26 ตุลาคม 2013, 20:47:58
โดย yod
xx
การทำ Route policy เพื่อกำหนดให้ website ออก wan ที่ต้องการ

เริ่มโดย yod เมื่อ อุปกรณ์ DrayTek (เดรเทค)

0 ตอบ
4979 อ่าน
กระทู้ล่าสุด วันที่ 22 มิถุนายน 2017, 18:49:04
โดย yod
xx
การทำ Domain Name Route Policy ระบุให้ออก Website ตาม WAN ที่กำหนด

เริ่มโดย yod เมื่อ อุปกรณ์ DrayTek (เดรเทค)

0 ตอบ
1317 อ่าน
กระทู้ล่าสุด วันที่ 24 กันยายน 2018, 16:15:11
โดย yod
 


Users found this pages searching for: