ผู้เขียน หัวข้อ: รวบรวม Script สำหรับ Mikrotik RouterBoard ที่จำเป็นต่อการใช้งาน  (อ่าน 25803 ครั้ง)

0 สมาชิก และ 2 บุคคลทั่วไป กำลังดูหัวข้อนี้

yod

  • บุคคลทั่วไป

รวบรวม Script สำหรับ RouterBoard ที่จำเป็นต่อการใช้งาน



เป็น Script ที่รวบรวมมา ปรับแต่งบ้าง ทดลองกับ RouterOS 4.11 ทำงานได้อย่างสมบูรณ์ครับ

ควรจะมีไว้นะครับ เพื่อช่วยให้ตัว Router Board ทำงานได้มีประสิทธิภาพยิ่งขึ้น โดยผมจะทยอยๆ Up ขึ้น Webboard หัวข้อนี้เรื่อยๆนะครับ


วิธีติดตั้ง Script

1. Login เข้า Winbox --> System --> Scripts

2. Click [ + ] เพื่อสร้าง New Script



ตั้งชื่อ Script ที่ ช่อง Name
จากนั้น Copy Script ที่ต้องการลงในช่อง Source
เสร็จแล้ว Click [OK]


3. เวลาต้องการ Run Script ก็เลือก Script ที่ Script List แล้ว Click [Run Script]





วิธีติดตั้ง Scheudler เพื่อตั้งเวลาการ Run Script

1. แก้ไข Code ด้านล่างครับ

/system scheduler add name=ClearUserSession interval=60:00:00 on-event="/system script run clear_user_session\r\n"

โดยที่
name=ชื่อ ของ Scheudler
interval=กำหนดเวลาในการ Run จากตัวอย่างจะเป็นทุกๆ 60 ชั่วโมง
run=ชื่อ Script ที่ต้องการ Run (อักษรตัวใหญ่ เล็ก มีผลนะครับ)



จากนั้นเคาะ Enter


2. สามารถแก้ไขเพิ่มเติมได้ที่ Menu System --> Scheudler






Script ต่างๆที่น่าจะติดตั้งไว้ครับ


[Remove UserMan Session]
ลบ Session ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

โค๊ด: [Select]
#Remove all session log in usermanager
:global i
:foreach i in=[/tool user-manager session find] do { /tool user-manager session remove $i; }

******************************************************************************

[Remove UserMan Log]
ลบ Log ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ และ Rebuild Database ให้ด้วยครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

โค๊ด: [Select]
#Remove all log in usermanager
:global i
:foreach i in=[/tool user-manager log find] do { /tool user-manager log remove $i; }
#Rebuild Database
/tool user-manager database rebuild

******************************************************************************

[Reboot RouterBoard เมื่อ System Memory < 5%]

โค๊ด: [Select]
#:global datum [/system clock get date];
:global time [/system clock get time];
:local percentfree ((100 * [/system resource get free-memory]) / [/system resource get total-memory])

/system resource
:if ($percentfree < 5) do={
/system reboot;
};

******************************************************************************
« แก้ไขครั้งสุดท้าย: วันที่ 21 เมษายน 2014, 15:30:11 โดย yod »

akthan

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 38
Re: รวบรวม Script สำหรับ RouterBoard ที่จำเป็นต่อการใช้งาน
« ตอบกลับ #1 เมื่อ: วันที่ 18 กุมภาพันธ์ 2012, 12:08:23 »
คุณยอด อยากได้ที่มันใช้บน OS 5.12 ได้ด้วยครับ เดี๋ยววันนี้จะลองลงบน  OS 5.12 ครับ

nightweekend

  • Ubiquiti Member
  • Newbie
  • *****
  • กระทู้: 15
    • อีเมล์
Re: รวบรวม Script สำหรับ RouterBoard ที่จำเป็นต่อการใช้งาน
« ตอบกลับ #2 เมื่อ: วันที่ 25 มิถุนายน 2012, 23:26:08 »
[Remove UserMan Session]
ลบ Session ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

โค๊ด:
#Remove all session log in usermanager
:global i
:foreach i in=[/tool user-manager session find] do { /tool user-manager session remove $i; }

******************************************************************************

[Remove UserMan Log]
ลบ Log ใน UserManager เพราะถ้าปล่อยทิ้งไว้นานๆจะทำให้ Memory ใน RouterBoard เต็มครับ และ Rebuild Database ให้ด้วยครับ ควรตั้งเวลาทุกๆ 200 ชั่วโมง

โค๊ด:
#Remove all log in usermanager
:global i
:foreach i in=[/tool user-manager log find] do { /tool user-manager log remove $i; }
#Rebuild Database
/tool user-manager database rebuild



ถามนิส ครับ คุณ ยอด ตั้ง เวลา ตรงไหน ครับ ผม  ??? ???

cgsupports

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 2
    • อีเมล์
Re: รวบรวม Script สำหรับ RouterBoard ที่จำเป็นต่อการใช้งาน
« ตอบกลับ #3 เมื่อ: วันที่ 24 กรกฎาคม 2012, 17:13:00 »
ผมใช้ 5.18 จะได้ไหมครับพี่ยอด


Share via facebook

xx
Config Wireless สำหรับ Module Wireless ในอุปกรณ์ Mikrotik RouterBoard

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
3614 อ่าน
กระทู้ล่าสุด วันที่ 15 ธันวาคม 2011, 22:34:40
โดย yod
xx
[แจก] ทางเลือกการจัดการ Usermanager ของ mikrotik + Script สำหรับลบ user expired

เริ่มโดย sup เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
1150 อ่าน
กระทู้ล่าสุด วันที่ 5 ตุลาคม 2018, 21:10:15
โดย sup
xx
Mikrotik reboot ตัวเองตลอดเวลา ถามทาง ThaiMikrotik บอกว่าโดน script virus

เริ่มโดย weera เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
1149 อ่าน
กระทู้ล่าสุด วันที่ 25 กรกฎาคม 2018, 10:23:22
โดย newsaendee
xx
การเขียน Script ตั้งเวลาการ Enable/Disable ค่าต่างๆ ในอุปกรณ์ Mikrotik

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
4906 อ่าน
กระทู้ล่าสุด วันที่ 5 สิงหาคม 2018, 10:07:06
โดย pc_wilalai
xx
แก้ไข Vouchers Template สำหรับ Mikrotik UserMan V5.xx

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

11 ตอบ
25150 อ่าน
กระทู้ล่าสุด วันที่ 27 มีนาคม 2015, 09:34:43
โดย yod
 


Users found this pages searching for: