ผู้เขียน หัวข้อ: โปรแกรม Syslog Server สำหรับเก็บ Log ร่วมกับ Mikrotik  (อ่าน 95861 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
โปรแกรม Syslog Server สำหรับเก็บ Log ร่วมกับ Mikrotik
« เมื่อ: วันที่ 25 ธันวาคม 2012, 13:13:10 »
    

โปรแกรม Syslog Server สำหรับเก็บ Log ใช้งานร่วมกับ Mikrotik







โปรแกรมนี้ผมทำให้ทดลองนำไปใช้งานกันโดยไม่มีค่าใช้จ่าย ติดปัญหาให้โพสในหัวข้อนี้เท่านั้นนะครับ ไม่รับ support ทางโทรศัพท์ครับ


พอดีมีลูกค้า Mikrotik สอบถามมาครับ เรื่อง Log ของตัว Routerboard ต้องการจะตรวจสอบ Error, Information ต่างๆ ผมก็เลยทำโปรแกรม Syslog Server แบบง่ายๆขึ้นมา โดยจะเก็บได้สูงสุด 65535 บรรทัด ถ้าเกินจะลบบรรทัดแรกออก (first in first out) ทีแรกจะให้ write ลง ไฟล์ทุกบรรทัดแทน แต่น่าจะมีปัญหาเรื่อง transaction ไม่ทัน

ส่วนการใช้งานร่วมกับอุปกรณ์ Router รุ่นอื่นๆ ผมยังไม่ได้ลองครับ ไม่แน่ใจว่า Syslog Raw Data มันจะมารูปแบบเดียวกันหรือเปล่า ถ้าลองแล้ว click ตรง debug แล้ว copy ตรง text box ด้านล่างของโปรแกรม post ในกระทู้นี้ให้ผมด้วยนะครับ  ;D


Download ได้ที่ Link จากนั้นก็แตกไฟล์ออกมา double click ที่โปรแกรมใช้งานได้เลยครับ ตั้งค่า IP Address ของเครื่อง Computer ที่ติดตั้งที่ menu Config


รายละเอียดการ Update software ผมจะให้อยู่ท้ายกระทู้นี้ครับ


การ config ตัว routerboard ให้ส่ง log ออกมาที่เครื่องที่ลงโปรแกรมครับ

1. เข้า Winbox --> System --> Logging
ที่ Tab Actions --> Click [ + ]
Name: syslog
Type: remote
Remote Address: IP Address ของเครื่องที่ลงโปรแกรม
Src Address: 0.0.0.0
Click [OK]





ที่ Tab Rules --> Click [ + ]
Topics: เลือกรูปแบบ Log ที่ต้องการ เช่น info, Warning, Error, Critical
Action: syslog

Click [OK]






ปล. โปรแกรมนี้เพื่อความรวดเร็วผมเลยเขียนแบบลูกทุ่งมาก  ;D ;D ;D
และเขียนแจกฟรี ไม่ขายแน่นอนครับ ถ้ามี bug หรือต้องการอะไรเพิ่มเติม แจ้งได้ที่หัวข้อนี้เท่านั้นนะครับ




//Updated 26/12/2012

เพิ่ม function การเก็บ log ไม่แน่ใจว่าตรงตาม พรบ.หรือเปล่าครับ แต่มีแสดง Date/Time, Login name, IP Address, Website ส่วน mac address เดี๋ยวหาอีกทีครับ




ก่อน Click Start ที่โปรแกรมให้ Click Main --> "Mode เก็บ log" ครับ จะมีการบันทึกลง text file ที่ folder log ของโปรแกรม


สร้าง Proxy ก่อน โดย ใช้ code ด้านล่างครับ แก้ไข ip address ให้ตรงกับขา lan ของ router (ใน code จะเป็น 192.168.1.1) ที่ใช้ แล้ว copy ลง terminal ใน winbox ได้เลยครับ ส่วนที่ tab rules ใน loging ให้เพิ่ม web-proxy กับ hotspot

โค๊ด: [Select]
/ip proxy
set enabled=yes
set src-address=0.0.0.0
set port=8080
set parent-proxy=0.0.0.0
set parent-proxy-port=0
set cache-administrator="webmaster"
set max-cache-size=none
set cache-on-disk=no
set max-client-connections=600
set max-server-connections=600
set max-fresh-time=3d
set always-from-cache=no
set cache-hit-dscp=4
set serialize-connections=no

/ip firewall nat add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp to-ports=8080

#/ip firewall filter
#add chain=input in-interface=pppoe-out1 src-address=0.0.0.0/0  protocol=tcp dst-port=8080 action=drop

เสร็จแล้วก็ลากมาไว้ด้านล่างสุดครับ






เพิ่ม Loging ในส่วนของ Proxy ทำตามรูปเลยครับ




และก็เพิ่ม log ในส่วน DHCP ด้วยครับ





หรือให้เก็บตอน User มีการ Login (ใน Usermanager ก็จะโชว์เหมือนกันนะครับ)


เข้าที่ Menu IP --> Hotspot --> User Profile
Double click ที่ User-Profile ที่สร้างไว้ ที่ tab script

เพิ่ม script ในส่วน on-login

โค๊ด: [Select]
:log info ("User login: $user")
:log info ("IP: ".$address)
:log info ("Mac Address:" $user mac-address)



เพิ่ม Loging ในส่วน Info จะได้ log ตามรูปครับ




++++++++++++++++++++
+        Release note.       +
++++++++++++++++++++
V.0.2.2
- Add filter6.
- Check box for auto save info log to text file.
- Add sysnet banner.

V.0.2.1
- Improve speed compare string > 40% .
- Add mode keep log.
- Add filter for check type of log.
- Writeline to texfile.
- Create log file by yyyymmdd.txt in log folder.

V.0.1.2
- add filter function.

V.0.1.1
- add debug mode for check raw data.
- add export log to text file.
« แก้ไขครั้งสุดท้าย: วันที่ 31 กรกฎาคม 2014, 14:02:26 โดย yod »

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server
« ตอบกลับ #1 เมื่อ: วันที่ 26 ธันวาคม 2012, 22:47:07 »
เดี๋ยวคืนนี้จะ run โปรแกรมค้างไว้ครับ จะทดสอบว่าตอนยิง log ไปเรื่อยๆช่วงกำลังเปลี่ยนวันจะเป็นยังไง  ;D

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server
« ตอบกลับ #2 เมื่อ: วันที่ 27 ธันวาคม 2012, 21:09:53 »
รันใน syslog ไม่ขึ้นครับ ไม่ขึ้นเหมือนคุณยอดนะครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server
« ตอบกลับ #3 เมื่อ: วันที่ 27 ธันวาคม 2012, 23:06:13 »

IP address ใน logging ส่วนของ remote ใส่ค่าเครื่องที่ลงโปรแกรม syslog นะครับ และในตัวโปรแกรมใส่หมายเลข ip ของเครื่องที่ลง ปิด/เปิด โปรแกรมแล้วกด start ครับ

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server
« ตอบกลับ #4 เมื่อ: วันที่ 28 ธันวาคม 2012, 08:10:05 »
ทำแล้วครับ แต่ไม่มี log ส่งมาที่โปรแกรม sysnetlog.exe ส่วนในตัว  mikrotik ไม่มีปัญหาครับ ที่ผมโพสว่ารัน syslog ไม่ขึ้น หมายถึง รันแล้วไม่ยอมส่งค่า log มาที่โปรแกรม sysnetlog ครับ ผมก็ทำตามขั้นตอนนะคับ จะเกี่ยวกับที่ผมทำ forward port remote 3389 ไว้ไหมครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server
« ตอบกลับ #5 เมื่อ: วันที่ 28 ธันวาคม 2012, 08:54:25 »

ลอง disable พวก windows firewall หรือ anti virus ด้วยนะครับ ส่วน forward port ไม่น่าเกี่ยวครับ เพราะใน proxy มันจะดักแค่ port 80 ให้ส่งต่อไป port 8080 เท่านั้นครับ

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server
« ตอบกลับ #6 เมื่อ: วันที่ 28 ธันวาคม 2012, 09:30:58 »
ครับ เดี๋ยวคืนนี้จะลองทำดูครับ ขอบคุณมากครับ

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server
« ตอบกลับ #7 เมื่อ: วันที่ 29 ธันวาคม 2012, 13:32:34 »
ไม่ได้อะครับ
nod ก็ปิดแล้ว firewall ก็ปิดแล้วครับ ไม่มี log ส่งมาเลยครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server
« ตอบกลับ #8 เมื่อ: วันที่ 29 ธันวาคม 2012, 14:42:18 »

ลองทดสอบในส่วน info log ให้ action เป็น remote แล้วชี้ ip address ไปที่เครื่องลงโปรแกรมดูก่อนครับ จากนั้นลอง disable/enable อะไรซักอย่างใน winbox แล้วดูว่ามี information ส่งมาที่โปรแกรมหรือเปล่าครับ

ผมลองทดสอบลงกับเครื่องที่ร้าน ใช้ได้ทุกเครื่องครับ จะมี xp, 7 และ 7 64bit

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server
« ตอบกลับ #9 เมื่อ: วันที่ 29 ธันวาคม 2012, 19:50:50 »
ไม่มีอะไรส่งมาเลยครับ

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server
« ตอบกลับ #10 เมื่อ: วันที่ 30 ธันวาคม 2012, 20:36:02 »
ส่ง log  จาก mikrotik เข้าเครื่องที่ลงโปรแกรม  ไม่ได้ครับ set  ให้ action เป็น remote แล้วชี้ ip address ไปที่เครื่องลงโปรแกรม แล้วครับ ก็ไม่ส่งค่าเหมือนเดิมครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server
« ตอบกลับ #11 เมื่อ: วันที่ 1 มกราคม 2013, 19:48:31 »

ลองทดสอบกับเครื่องเปล่าๆที่ลงแค่ windows ดูครับ

ตอนนี้มีลูกค้านำไปทดสอบกับเครื่อง atom มี user online ประมาณ 20 คน ใช้ได้ปกติครับ

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #12 เมื่อ: วันที่ 2 มกราคม 2013, 10:55:01 »
เป็นที่เครื่องผมครับ ลองเครื่องอื่นได้ครับ ขอบคุณครับ

yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #13 เมื่อ: วันที่ 3 มกราคม 2013, 08:07:47 »
Nod มันบล็อคนะครับ เอา Nod32 ออกรันได้ปกติครับ จะแก้ยังไงดีครับคุณยอด ไม่อยากเอา Nod ออกนะครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #14 เมื่อ: วันที่ 3 มกราคม 2013, 12:43:14 »

ในตัวโปรแกรม nod น่าจะมี function ไม่ต้อง block บาง software นะครับ ผมใช้ kaspersky ก็มีให้เลือกครับ

vitcz75

  • Newbie
  • *
  • กระทู้: 1
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #15 เมื่อ: วันที่ 26 มกราคม 2013, 22:04:06 »
สร้าง Proxy ก่อน โดย ใช้ code ด้านล่างครับ แก้ไข ip address ให้ตรงกับขา lan ของ router (ใน code จะเป็น 192.168.1.1) ที่ใช้ แล้ว copy ลง terminal ใน winbox ได้เลยครับ ส่วนที่ tab rules ใน loging ให้เพิ่ม web-proxy กับ hotspot

โค๊ด:
/ip proxy
set enabled=yes
set src-address=0.0.0.0
set port=8080
set parent-proxy=0.0.0.0
set parent-proxy-port=0
set cache-administrator="webmaster"
set max-cache-size=none
set cache-on-disk=no
set max-client-connections=600
set max-server-connections=600
set max-fresh-time=3d
set always-from-cache=no
set cache-hit-dscp=4
set serialize-connections=no

/ip firewall nat add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp to-ports=8080

#/ip firewall filter
#add chain=input in-interface=pppoe-out1 src-address=0.0.0.0/0  protocol=tcp dst-port=8080 action=drop

แก้ ip address ตรงไหนคับ ที่ว่าในโค้ตเปน192.168.1.1

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #16 เมื่อ: วันที่ 28 มกราคม 2013, 12:52:26 »


ขอบคุณมากๆเลยครับ  ;D ;D


yuttapong

  • Mikrotik
  • Full Member
  • *****
  • กระทู้: 245
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #17 เมื่อ: วันที่ 30 มกราคม 2013, 16:18:37 »
คุณยอด syslog server ใช้กับระบบโดเมนได้ไหมครับ

tesco

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 10
    • อีเมล์
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #18 เมื่อ: วันที่ 3 เมษายน 2013, 21:22:38 »
สร้าง Proxy ก่อน โดย ใช้ code ด้านล่างครับ แก้ไข ip address ให้ตรงกับขา lan ของ router (ใน code จะเป็น 192.168.1.1) ที่ใช้ แล้ว copy ลง terminal ใน winbox ได้เลยครับ ส่วนที่ tab rules ใน loging ให้เพิ่ม web-proxy กับ hotspot

โค๊ด:
/ip proxy
set enabled=yes
set src-address=0.0.0.0
set port=8080
set parent-proxy=0.0.0.0
set parent-proxy-port=0
set cache-administrator="webmaster"
set max-cache-size=none
set cache-on-disk=no
set max-client-connections=600
set max-server-connections=600
set max-fresh-time=3d
set always-from-cache=no
set cache-hit-dscp=4
set serialize-connections=no

/ip firewall nat add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp to-ports=8080

#/ip firewall filter
#add chain=input in-interface=pppoe-out1 src-address=0.0.0.0/0  protocol=tcp dst-port=8080 action=drop

แก้ ip address ตรงไหนคับ ที่ว่าในโค้ตเปน192.168.1.1

ไม่เห็นเข้ามาตอบเลยครับ


[/quote]

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1876
    • Sysnet Center
Re: โปรแกรม Syslog Server สำหรับเก็บ Log
« ตอบกลับ #19 เมื่อ: วันที่ 4 เมษายน 2013, 12:39:04 »
ไม่เห็นเข้ามาตอบเลยครับ



ลืมไปเลยครับ  :D

ไม่ต้องแก้ไขครับ Copy ได้เลย


Share via facebook

xx
โปรแกรม SysNetLog สำหรับเก็บ SysLog หรือ เก็บ Log จาก Mikrotik

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
5731 อ่าน
กระทู้ล่าสุด วันที่ 19 พฤษภาคม 2015, 13:07:35
โดย yod
xx
การ Config Mikrotik ทำระบบ Hotspot แบบ PPPoE Server ร่วมกับ WRT54GL

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

8 ตอบ
42775 อ่าน
กระทู้ล่าสุด วันที่ 27 มิถุนายน 2018, 16:38:40
โดย Mawwan
xx
การ Config Mikrotik เพื่อเก็บ Log Internet ด้วย Kiwi Syslog หรือ Syslog Watcher

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

5 ตอบ
18474 อ่าน
กระทู้ล่าสุด วันที่ 15 กรกฎาคม 2014, 12:49:04
โดย pac7584
xx
ขอสอบถามเรื่องการใช้ wifi 2 จุดครับ ร่วมกับ mikrotik

เริ่มโดย suwanna เมื่อ อุปกรณ์ Mikrotik Router

5 ตอบ
4681 อ่าน
กระทู้ล่าสุด วันที่ 19 มีนาคม 2012, 23:51:29
โดย yod
xx
การใช้งาน Handlink WG-500P ร่วมกับ Mikrotik Router

เริ่มโดย yod เมื่อ แนะนำสินค้าน่าใช้, Review Product

4 ตอบ
11472 อ่าน
กระทู้ล่าสุด วันที่ 18 กรกฎาคม 2014, 12:31:15
โดย yod
 


Users found this pages searching for: