ผู้เขียน หัวข้อ: การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube  (อ่าน 21852 ครั้ง)

0 สมาชิก และ 2 บุคคลทั่วไป กำลังดูหัวข้อนี้

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1846
    • Sysnet Center
การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
« เมื่อ: วันที่ 28 พฤศจิกายน 2014, 17:07:27 »

การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube


มีลูกค้าสอบถามเข้ามาครับ ต้องการกำหนดช่วงเวลาการใช้งาน Youtube แต่จะ Block ไม่ให้ใช้เลยก็ดูไม่ดี เลยจะใช้เป็นการบีบความเร็วลงจะดีกว่า


1. Login เข้า Winbox

เข้า Menu IP --> Firewall --> Layer7 Protocols

สร้าง L7 Expression ของ Youtube
Name: youtube
Regexp: ^.+(youtube).*$



Click [OK]

หรือ Run scrip ตามนี้

โค๊ด: [Select]
/ip firewall layer7-protocol add comment="" name=youtube regexp="Regexp: ^.+(youtube).*$"

2. สร้าง Mangle เพื่อจับ Packet youtube

IP --> Firewall --> Mangle

Tab General
Chain: prerouting



Tab Advanced
Layer7 Protocol: youtube



Tab Action
Action: mark packet
New Packet Mark: mp-youtube



ใส่ Comment เป็น mp-youtube



Click [OK]

โค๊ด: [Select]
/ip firewall mangle
add action=mark-packet chain=prerouting \
comment="mp-youtube" disabled=no \
layer7-protocol=youtube new-packet-mark=mp-youtube \
passthrough=no

ทดสอบเปิด Youtube จะต้องมี Packet วิ่ง




3. กำหนด Queue
Menu Queue --> Queue Tree
Tab General

Name: q-youtube
Parent: global
Packet Marks: mp-youtube
Queue Type: default
Max Limit: 128k (ปรับเปลี่ยนตามต้องการครับ)



Click [OK]

ทดสอบเปิด Youtube จะต้องมี Packet วิ่ง และ Status เป็นสีแดง แสดงว่า Queue ทำงานแล้วครับ




4. ทีนี้จะเป็นการสร้าง Script เพื่อ Enable/Disable ครับ ซึ่งผมได้อธิบายไว้อย่างละเอียดในหัวข้อนี้ครับ (สำหรับสมาชิก Mikrotik Groupt นะครับ)การเขียน Script Schedule Enable/Disable ในอุปกรณ์ Mikrotik

สร้าง Script สำหรับการ Enable
Name: enable-mp-youtube
Source: /ip firewall mangel enable [find comment=mp-youtube]



Click [OK]

สร้าง Script สำหรับการ Disable
Name: disable-mp-youtube
Source: /ip firewall mangel disable [find comment=mp-youtube]



Click [OK]

ลองทดสอบ Run Script ดูด้วยนะครับ




5. ทีนี้จะเป็นการสร้าง Schedule ตัวอย่างจะเป็นการกำหนด Bandwidthช่วงเวลา 8.00-12.00 และ 13.00-17.00 ตรวจสอบเวลาของตัว Mikrotik ให้เรียบร้อยด้วยนะครับ System --> Clock

Copy Script เลยง่ายกว่า

โค๊ด: [Select]
system scheduler add name=sch-enable-mpyoutube start-date=nov/06/2012 start-time=08:00:00 interval=1d on-event=enable-mp-youtube policy=read,write
system scheduler add name=sch-disable-mpyoutube start-date=nov/06/2012 start-time=12:00:00 interval=1d on-event=disable-mp-youtube policy=read,write

system scheduler add name=sch-enable-mpyoutube2 start-date=nov/06/2012 start-time=13:00:00 interval=1d on-event=enable-mp-youtube policy=read,write
system scheduler add name=sch-disable-mpyoutube2 start-date=nov/06/2012 start-time=17:00:00 interval=1d on-event=disable-mp-youtube policy=read,write





จะได้ตามนี้ครับ





เรียบร้อย  ;D ;D

pphat21

  • Newbie
  • *
  • กระทู้: 1
    • อีเมล์
Re: การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
« ตอบกลับ #1 เมื่อ: วันที่ 13 กุมภาพันธ์ 2015, 10:35:03 »
ผมลองเซ็ตตามที่แนะนำแล้ว แต่ผมไม่ได้ตั้งเวลาว่าจะจำกัดเวลาไหนบ้าง คือผมอยากให้จำกัดตลอดเลย แต่ปรากฏว่าเข้าเว็บ youtube ไม่ได้เลย แต่พอลบค่าที่เซ็ตไว้ทั้งหมดออกเข้าได้ ไม่ทราบว่าผมต้องแก้ไขยังไงครับ

Wirasak.G

  • Newbie
  • *
  • กระทู้: 1
Re: การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
« ตอบกลับ #2 เมื่อ: วันที่ 18 กุมภาพันธ์ 2015, 12:11:22 »

ลองไปเพิ่ม Max limit ที่ Queue tree ดูครับ  ;D

jobzaaclub

  • Newbie
  • *
  • กระทู้: 15
Re: การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
« ตอบกลับ #3 เมื่อ: วันที่ 11 พฤศจิกายน 2015, 18:31:35 »
ได้แล้วครับ ขอบคุณมากครับ
« แก้ไขครั้งสุดท้าย: วันที่ 11 พฤศจิกายน 2015, 18:51:59 โดย jobzaaclub »

jobzaaclub

  • Newbie
  • *
  • กระทู้: 15
Re: การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
« ตอบกลับ #4 เมื่อ: วันที่ 13 พฤศจิกายน 2015, 18:07:13 »
สอบถามเพิ่มครับ
ถ้าจะให้ disable ช่วง เสาร์-อาทิตย์ด้วยต้องไปแก้ไขยังไงครับ

jobzaaclub

  • Newbie
  • *
  • กระทู้: 15
Re: การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
« ตอบกลับ #5 เมื่อ: วันที่ 19 พฤศจิกายน 2015, 09:50:41 »
ผมทำให้มัน diable เสาร์อาทิตย์ได้แล้วครับ
แต่อยากรู้ว่าถ้าจะยกเลิกการจำกัดเป็นราย user จะทำยังไงครับ

isatnarok

  • Newbie
  • *
  • กระทู้: 2
Re: การตั้งเวลา และ จำกัด Bandwidth การใช้งาน Youtube
« ตอบกลับ #6 เมื่อ: วันที่ 8 เมษายน 2017, 11:05:20 »
การเขียน Script Schedule Enable/Disable ในอุปกรณ์ Mikrotik เปิดไม่ได้หรือไม่มีแล้วครับ


Share via facebook

xx
จำกัด bandwidth เป็น ช่วง IP ได้ไหมครับ ?

เริ่มโดย tpfresh เมื่อ อุปกรณ์ Mikrotik Router

3 ตอบ
1165 อ่าน
กระทู้ล่าสุด วันที่ 18 กรกฎาคม 2013, 13:56:44
โดย tpfresh
xx
จำกัด bandwidth โดยแบ่งเป็น IP range/ specific IP อย่างไรครับ

เริ่มโดย instep381 เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
1136 อ่าน
กระทู้ล่าสุด วันที่ 22 กุมภาพันธ์ 2017, 17:05:16
โดย yod
xx
การตั้งเวลา Reboot อุปกรณ์ Mikrotik Routerboard

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
23337 อ่าน
กระทู้ล่าสุด วันที่ 3 ตุลาคม 2015, 20:49:04
โดย สองสลึง
xx
การตั้งเวลา Reboot อุปกรณ์ Access Point ของ UBiQUiTi โดยอัตโนมัติ

เริ่มโดย Mr.Zenith เมื่อ อุปกรณ์ UBiQUiTi (ยูบิ-คิวตี้)

0 ตอบ
11658 อ่าน
กระทู้ล่าสุด วันที่ 14 มกราคม 2014, 20:23:58
โดย Mr.Zenith
xx
ตั้งค่า จำกัด ความเร็ว อย่างไรคับ RB1100AHx4 v.6.43

เริ่มโดย kingjam88 เมื่อ อุปกรณ์ Mikrotik Router

7 ตอบ
927 อ่าน
กระทู้ล่าสุด วันที่ 9 ตุลาคม 2018, 15:43:04
โดย yod
 


Users found this pages searching for: