ผู้เขียน หัวข้อ: ใช้ตัว Mikrotik : RB2011UiAS-2HnD-IN ทำ Load balance แต่เน็ตไม่ออกครับ  (อ่าน 2498 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

kengertik

  • Newbie
  • *
  • กระทู้: 2
    • อีเมล์
ใช้ตัว Mikrotik : RB2011UiAS-2HnD-IN ทำ Load balance แต่เน็ตไม่ออกครับ
« เมื่อ: วันที่ 26 พฤศจิกายน 2015, 09:48:05 »
ผมลองเอาโค้ดมาปรับแก้เอง  คือถ้าเสียบอินเตอร์เน็ตเส้นเดี่ยว(เฉพาะ port 1)จะใช้งานปกติ  ถ้าเสียบ 2 เส้นเน็ตจะหลุดทั้นที (port 1 True 15/1 : port 2 tot fiber 50/20)

โค้ดตามนี้ครับ  ขอคำชี้่แนะด้วยครับ  
ใช้ตัว RB2011UiAS-2HnD-IN FW:V6.34rc3 ทำ Loadbalannce  ปัญหาตอนนี้คือ ถ้าเสียบเน็ตเข้าไป 2 เส้นเน็ตทั้ง Lan จะหลุดไปทั้งหมด  แต่ดูจาก interface เน็ตทั้งสองเส้นไม่ได้หลุด  ครับ  จึงยากขอคำชี้แนะด้วยครับ  (มือใหม่ครับ  หาข้อมูลมาปรับแก้)

โค้คที่ผมเอามาปรับแก้ครับ
#|/ip address
/ip address add address=192.168.1.1/24 network=192.168.1.0 broadcast=192.168.1.255 interface=ether5  comment="default configuration"
#master port
#/interface ethernet set ether4,ether5 master-port=ether3
#|/ip firewall mangle
/ip firewall mangle add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=ether1_conn
/ip firewall mangle add chain=input in-interface=pppoe-out2 action=mark-connection new-connection-mark=ether2_conn
/ip firewall mangle add chain=output connection-mark=ether1_conn action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2

#|Speed Balance 15/60=1:4
/ip firewall mangle add chain=preroutingdst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:5/0 action=mark-connection new-connection-mark=ether1_conn passthrough=yes
/ip firewall mangle add chain=preroutingdst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:5/1 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
/ip firewall mangle add chain=preroutingdst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:5/2 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
/ip firewall mangle add chain=preroutingdst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:5/3 action=mark-connection new-connection-mark=ether2_conn passthrough=yes
/ip firewall mangle add chain=preroutingdst-address-type=!local in-interface=ether5 per-connection-classifier=both-addresses-and-ports:5/4 action=mark-connection new-connection-mark=ether2_conn passthrough=yes

/ip firewall mangle add chain=prerouting connection-mark=ether1_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether1
/ip firewall mangle add chain=prerouting connection-mark=ether2_conn in-interface=ether5 action=mark-routing new-routing-mark=to_ether2

#|/iproute
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_ether1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=to_ether2 check-gateway=ping

/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
/ip route add dst-address=0.0.0.0/0 gateway=pppoe-out2 distance=2 check-gateway=ping

#|/ip firewall nat
/ip firewall nat add chain=srcnat out-interface=pppoe-out1 action=masquerade
/ip firewall nat add chain=srcnat out-interface=pppoe-out2 action=masquerade

#| DHCP server is on switch, with address pool 192.168.1.30-192.168.1.79
/ip pool add name=default-dhcp ranges=192.168.1.30-192.168.1.79
/ipdhcp-server add name=default address-pool=default-dhcp interface=ether5 disabled=no
/ipdhcp-server network add address=192.168.1.0/24 gateway=192.168.1.1 dns-server=8.8.8.8,8.8.4.4 comment="default configuration"

#| DNS
#/ipdns set allow-remote-requests=yes
#/ipdns static add name=router address=192.168.1.1

#| Now Configure DNS server so users can resolve hostnames,
#| Ex.cache-size=5000KiB
#| DNS Google = 8.8.8.8,8.8.4.4
#| DNS 3BB = 110.164.252.222,110.164.252.223
/ipdns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000K max-udp-packet-size=512 servers=8.8.8.8,8.8.4.4


Share via facebook

xx
เก็บ log จาก Mikrotik RB2011UiAS-2HnD-IN

เริ่มโดย megic_m เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
2138 อ่าน
กระทู้ล่าสุด วันที่ 26 สิงหาคม 2015, 14:57:38
โดย panita
xx
Mikrotik RB2011UiAS-2HnD-IN ทำ Hostpot ด้วยตัวมันเองได้ไหมครับ

เริ่มโดย liponlamon เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
1485 อ่าน
กระทู้ล่าสุด วันที่ 3 กรกฎาคม 2015, 09:13:24
โดย liponlamon
xx
ช่วยด้วยครับ Mikrotik RB2011UiAS-2HnD-IN ทำเป็น hotspot แต่ยังใช้ไม่ได้ซักที

เริ่มโดย toodti เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
2436 อ่าน
กระทู้ล่าสุด วันที่ 16 พฤษภาคม 2016, 14:10:25
โดย yod
xx
Upgrade Firmware ของ Router Mikrotik ( รุ่น RB2011UiAS-2HnD ) เครื่องรีบู๊ทตลอด

เริ่มโดย iamwiroj เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
1076 อ่าน
กระทู้ล่าสุด วันที่ 30 ธันวาคม 2016, 15:13:11
โดย yod
xx
mikrotik Load Balance&Vlan

เริ่มโดย manmusic เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
1014 อ่าน
กระทู้ล่าสุด วันที่ 25 เมษายน 2018, 09:54:34
โดย manmusic
 


Users found this pages searching for: