ผู้เขียน หัวข้อ: มีปัญหา Loadbalance 2 Wan แบบ PPPoE Client, DHCP Client  (อ่าน 1055 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

aladin36

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 1
    • อีเมล์
มีปัญหา Loadbalance 2 Wan แบบ PPPoE Client, DHCP Client
« เมื่อ: วันที่ 21 กุมภาพันธ์ 2017, 11:39:04 »
ผมทำตามสคลิปนี้ครับ Loadbalance 2 Wan แบบ PPPoE 30/15 Client, DHCP Client 100/50 มีปัญหาตรงที่ 1. เวลาใช้ 2 เส้น เน็ตอืดมากเข้าหน้าเว็บ ได้บ้างไม่ได้บ้าง 2. เวลาเน็ตอีกเส้นดับใช้เวลาประมาณ 5 นาที ถึงจะวิ่งอีกเส้น แต่วิ่งได้เร็ว ครับ ต้องมีอะไรหรือแก้อะไรเพิ้มครับ

/ip firewall mangle
 
add action=accept chain=prerouting disabled=no in-interface=pppoe-out1
add action=accept chain=prerouting disabled=no in-interface=ether2
 
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 src-address=192.168.2.0/24
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1 src-address=192.168.2.0/24
 
add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes src-address=192.168.2.0/24
add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes src-address=192.168.2.0/24
 
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=pppoe-out1 src-address=192.168.2.0/24
add action=masquerade chain=srcnat disabled=no out-interface=ether2 src-address=192.168.2.0/24

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_wan1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether2 routing-mark=to_wan2 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether2 scope=30 target-scope=10

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1828
    • Sysnet Center
Re: มีปัญหา Loadbalance 2 Wan แบบ PPPoE Client, DHCP Client
« ตอบกลับ #1 เมื่อ: วันที่ 21 กุมภาพันธ์ 2017, 13:29:26 »
ไม่ได้แตะ loadbalance บน mikrotik นานมากแล้วครับ

ลองแก้ตามนี้ครับ

add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/0 src-address=192.168.2.0/24
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/1 src-address=192.168.2.0/24
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/2 src-address=192.168.2.0/24
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:4/3 src-address=192.168.2.0/24

Aussares Thepnarin

  • Newbie
  • *
  • กระทู้: 1
    • อีเมล์
Re: มีปัญหา Loadbalance 2 Wan แบบ PPPoE Client, DHCP Client
« ตอบกลับ #2 เมื่อ: วันที่ 15 กันยายน 2018, 20:30:24 »
ของผมมี 2เส้น
wan1 100mbps distance 1
wan2 4 mbps มือถือผ่าน lan distance 100   

ตั้งใจทำ backup
ตั้งพอใช้งาน มันหน่วงๆตอนแรกทุกที คือ ตอนแรกจะช้าตลอดพอสักพักจะเร็ว เหมือนมันกำลังเช็คก่อนทุกครั้งทำให้เสียเวลามาก ตอนนี้เลยต้อง Disable เส้น wan2 ไปก่อนเพื่อให้ใช้งานปกติ

ไม่ทราบทำไงให้มันเร็วเหมือน wan1 เส้นเดียวได้บ้าง โดยไม่ต้องไป Disable wan2

ขอบคุณครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1828
    • Sysnet Center
Re: มีปัญหา Loadbalance 2 Wan แบบ PPPoE Client, DHCP Client
« ตอบกลับ #3 เมื่อ: วันที่ 17 กันยายน 2018, 15:07:52 »

หน่วงๆนี้คือตอนเปิด browser เข้า web หรือเปล่าครับ ลองเปลี่ยน dns เป็น 8.8.8.8 ดูครับ


Share via facebook

xx
Script Loadbalance 2 Wan แบบ PPPoE Client, DHCP Client และ Static IP

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

6 ตอบ
10545 อ่าน
กระทู้ล่าสุด วันที่ 6 มิถุนายน 2018, 11:28:14
โดย bobmberman
xx
ขอ Script Loadbalance 3 Wan DHCP Client หน่อยครับ

เริ่มโดย soundboombass เมื่อ อุปกรณ์ Mikrotik Router

3 ตอบ
1060 อ่าน
กระทู้ล่าสุด วันที่ 24 มีนาคม 2017, 08:51:25
โดย soundboombass
xx
ขอวิธี VPN IPSEC Client to site โดยใช้ Cisco Vpn Client

เริ่มโดย intsups เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
1814 อ่าน
กระทู้ล่าสุด วันที่ 13 กรกฎาคม 2016, 23:04:11
โดย intsups
xx
สอบถาม script ตั้งเวลาปิด/เปิด pppoe-client

เริ่มโดย komkrish4210 เมื่อ อุปกรณ์ Mikrotik Router

1 ตอบ
847 อ่าน
กระทู้ล่าสุด วันที่ 13 ตุลาคม 2014, 10:21:46
โดย yod
xx
การ Config Ubiquiti Air-Router HP ใน Mode PPPoE Client

เริ่มโดย yod เมื่อ อุปกรณ์ UBiQUiTi (ยูบิ-คิวตี้)

0 ตอบ
6518 อ่าน
กระทู้ล่าสุด วันที่ 18 สิงหาคม 2012, 17:50:52
โดย yod
 


Users found this pages searching for: