ผู้เขียน หัวข้อ: คู่มือการทำ L3 Based VLAN บนอุปกรณ์ Cisco SG350 Series  (อ่าน 680 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1860
    • Sysnet Center
คู่มือการทำ L3 Based VLAN บนอุปกรณ์ Cisco SG350 Series
« เมื่อ: วันที่ 12 มิถุนายน 2019, 13:12:39 »

คู่มือการทำ L3 Based VLAN บนอุปกรณ์ Cisco SG350 Series



เป็นงานที่ทางร้าน Config ส่งให้ลูกค้าครับ ลูกค้าต้องการแยกวง Network เป็น 2 วง สำหรับ Guest และ Staff โดยใช้ Switch Cisco SG350-28 เป็น Core Switch และ Cisco SG350-10 สำหรับเชื่อมต่อแต่ละแผนก




ในตัวอย่างนี้ผมยังไม่ได้ทำเรื่อง Trunk เดี๋ยวถ้าว่างจะทำเป็นอีกหัวข้อนึงนะครับ สำหรับนำ VLAN หลายๆ VLAN ส่งไปยัง Switch ตัวอื่น รวมถึง Access Point เพื่อทำ SSID VLAN Mapping ด้วยครับ


IP Address ของ Router ที่ Switch เชื่อมต่อจะเป็น 192.168.20.1


หน้าจอ Config ของ Cisco SG350 Series บน Firmware ตัวใหม่ หน้าจอเยอะมากกกก ขอเป็น config ผ่าน console ละกันครับ และเนื่องจากผมรีบส่งให้ลูกค้า อาจจะมีรูปตกหล่นไปบ้างต้องขออภัยด้วยนะครับ


ผมใช้สาย console ที่แปลงเป็น usb ให้เรียบร้อยครับ สะดวกดี




ส่วนโปรแกรมจะใช้ Putty หรือ SecureCRT ก็สะดวกดีครับ จะ detect Baudrate ให้อัตโนมัติเลย

User/Password จะเป็น cisco/cisco เมื่อ Login ครั้งแรกตัวอุปกรณ์จะบังคับให้เปลี่ยน User และ Password ครับ


ตั้งชื่อให้ Switch Cisco SG350

switch-name#config terminal
switch-name(config)#hostname SW-CORE


ใน VLAN1 บน Switch Cisco จะมี Default เป็น DHCP Client ให้ทำการยกเลิกก่อนครับ ไม่อย่างนั้นจะไม่สามารถ Enable DHCP Server ได้




ยกเลิก DHCP เข้า Interface Config ของ VLAN 1

switch-name(config-if)#no ip address dhcp




Fix IP Address ให้กับ VLAN1

SW-CORE(config)#int vlan 1
SW-CORE(config-if)#ip address 192.168.20.2 255.255.255.0
SW-CORE(config-if)#ip default-gateway 8.8.8.8




เชื่อมต่อสาย Lan จาก Port Lan ของ Router เข้า SG350-28 ให้เรียบร้อย

ทดสอบ Ping ไปที่ 8.8.8.8 ครับ




Enable DHCP Server

SW-CORE(config)#ip dhcp server




จัดการให้ Switch สามารถ resolve dns เพื่อเข้า web ได้

SW-CORE(config)#ip domain-lookup
SW-CORE(config)#ip name-server 8.8.8.8




สร้าง VLAN 20

SW-CORE(config)#vlan 20
SW-CORE(config)#int vlan 20
SW-CORE(config-if)#name Guest

Fix IP ให้ VLAN 20

SW-CORE(config-if)#ip address 172.16.0.1 255.255.255.0
SW-CORE(config-if)#exit




สร้าง DHCP Pool ให้ VLAN 20

SW-CORE(config)#ip dhcp pool network GuestPool
SW-CORE(config-dhcp)#address low 172.16.0.30 high 172.16.3.254 255.255.252.0
SW-CORE(config-dhcp)#default router 172.16.0.1
SW-CORE(config-dhcp)#dns-server 8.8.8.8
SW-CORE(config-dhcp)#domain-name Guest
SW-CORE(config-dhcp)#exit




จัดการให้ Port G1 และ G2 เป็นสมาชิก VLAN 20

SW-CORE(config)#interface range g1-2
SW-CORE(config-if-range)#switchport mode access
SW-CORE(config-if-range)#switchport access vlan 20
SW-CORE(config-if-range)#exit




ตรวจสอบ IP, VLAN

SW-CORE#show vlan
SW-CORE#show ip interface

ตรวจสอบ DHCP Pool

SW-CORE#show ip dhcp pool network




บันทึกค่า Config

กรณีถ้าเราไม่ได้ Save ค่า Config พอ Reboot ตัว Switch ค่าจะกลับมาเป็นค่าเดิมที่เรา Save ไว้ล่าสุด แต่ถ้าเราไม่เคย Save เลย ก็จะกลายเป็นค่า Default ไปครับ

SW-CORE#copy run start




ส่วน VLAN 30 ก็ทำเหมือนกับ VLAN ครับ
สร้าง VLAN 30, กำหนดชื่อ Staff
กำหนด IP Address 10.0.1.1/24
สร้าง DHCP Pool PoolStaff 10.0.1.30-10.0.1.254, default router เป็น 10.0.1.1
กำหนด Port G3,4 ให้เป็นสทาชิก VLAN30







ที่นี้ก็จะเป็น Switch ตัวที่ 2 ครับ จะยกตัวอย่าง Switch ตัวที่เป็น 10.0.1.2/24 ครับ

ตั้งชื่อเป็น SW-STAFFและ Disable DHCP Client

SW-STAFF(config)#interface vlan 1
SW-STAFF(config-if)#no ip address dhcp




Fix IP ให้ VLAN 1

SW-STAFF(config-if)#ip address 10.0.1.2 255.255.255.0
SW-STAFF(config-if)#exit

กำหนด Default Gateway และ DNS

SW-STAFF(config)#ip default-gateway 10.0.1.1
SW-STAFF(config)#ip domain lookup
SW-STAFF(config)#ip name-server 8.8.8.8




แล้วลอง Ping ทดสอบครับ




ที่สำคัญ..อย่าลืมทำ Static Route บน Router ไว้ด้วยนะครับ

ส่วนใหญ่ก็จะประมาณนี้เลย

Destination IP Address: วง Subnetwork ปลายทาง (172.16.0.0)
Subnet Mask: Subnet mask ของ วง Network ปลายทาง (255.255.252.0)
Gateway IP Address: หมายเลข IP ของอุปกรณ์ที่ Router เชื่อมต่ออยู่ ในตัวอย่างคือหมายเลข IP 192.168.20.2

สร้าง Static Route ของวง 10.0.1.0/24 ด้วยนะครับ ใช้หลักการเดียวกัน


เรียบร้อยครับ  ;D ;D

suphakorn

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 4
    • อีเมล์
Re: คู่มือการทำ L3 Based VLAN บนอุปกรณ์ Cisco SG350 Series
« ตอบกลับ #1 เมื่อ: วันที่ 10 กรกฎาคม 2019, 21:58:47 »
ทำauthenกับmikrotikได้ไหม... ครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1860
    • Sysnet Center
Re: คู่มือการทำ L3 Based VLAN บนอุปกรณ์ Cisco SG350 Series
« ตอบกลับ #2 เมื่อ: วันที่ 11 กรกฎาคม 2019, 10:56:29 »

ถ้าเป็น authen ที่เป็น hotspot บน mikrotik จะเป็น mac base ครับ ค่า mac address จะไม่สามารถข้าม l3 ได้ครับ

ต้องใช้พวก 802.1x ครับ

suphakorn

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 4
    • อีเมล์
Re: คู่มือการทำ L3 Based VLAN บนอุปกรณ์ Cisco SG350 Series
« ตอบกลับ #3 เมื่อ: วันที่ 13 กรกฎาคม 2019, 13:11:30 »
 ::)
« แก้ไขครั้งสุดท้าย: วันที่ 17 กรกฎาคม 2019, 16:43:59 โดย suphakorn »


Share via facebook

xx
สอบถามเรื่องการทำ mac based vlan ครับ

เริ่มโดย smjtheoff เมื่อ อุปกรณ์ Cisco, Linksys By Cisco

0 ตอบ
3605 อ่าน
กระทู้ล่าสุด วันที่ 1 มิถุนายน 2012, 16:28:21
โดย smjtheoff
xx
ทำ VLAN Trunking เพื่อเชื่อม VLAN บน Cisco Managed Switch 2 ชุด ตอนที่ 2

เริ่มโดย yod เมื่อ อุปกรณ์ Cisco, Linksys By Cisco

1 ตอบ
9246 อ่าน
กระทู้ล่าสุด วันที่ 5 สิงหาคม 2015, 11:05:23
โดย auyaay
xx
ทำ VLAN Trunking เพื่อเชื่อม VLAN บน Cisco Managed Switch 2 ชุด ตอนที่1

เริ่มโดย yod เมื่อ อุปกรณ์ Cisco, Linksys By Cisco

0 ตอบ
12275 อ่าน
กระทู้ล่าสุด วันที่ 31 กรกฎาคม 2015, 23:48:14
โดย yod
xx
สอบถามการทำ Vlan บนอุปกรณ์ IP-COM G3210P L2-Managed

เริ่มโดย bp_prem เมื่อ อุปกรณ์ IP-COM (ไอพี-คอม)

4 ตอบ
8269 อ่าน
กระทู้ล่าสุด วันที่ 22 พฤษภาคม 2017, 11:47:12
โดย Lazerosa
xx
cisco SG200-50 ตั้งค่า vlan ยังไงครับ

เริ่มโดย yuttapong เมื่อ อุปกรณ์ Cisco, Linksys By Cisco

0 ตอบ
3629 อ่าน
กระทู้ล่าสุด วันที่ 13 มิถุนายน 2015, 15:02:21
โดย yuttapong
 


Users found this pages searching for: