ผู้เขียน หัวข้อ: Block Bittorrent ด้วย Mikrotik Router Board  (อ่าน 13405 ครั้ง)

0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้

yod

  • บุคคลทั่วไป
Block Bittorrent ด้วย Mikrotik Router Board
« เมื่อ: วันที่ 7 มีนาคม 2011, 19:04:19 »

Block Bittorrent ด้วย Mikrotik Router Board



#15/06/2017
เพิ่มเติมในกรณี Upgrade Router OS 6.39 แล้ว Block Bittorrent ไม่ผ่าน ให้ลองใช้ Script นี้นะครับ



/ip firewall layer7-protocol
add comment="Block Bit Torrent - tabela regex" name=layer7-bittorrent-exp regexp=\
    "^(\\x13bittorrent protocol|azver\\x01\$|get /scrape\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet/|GET /data\\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]"

/ip firewall filter
add action=add-src-to-address-list address-list=Torrent-Conn address-list-timeout=5m chain=forward comment="Block torrent trafic" layer7-protocol=layer7-bittorrent-exp \
    log-prefix=torr-conn src-address=192.168.2.0/24 src-address-list=!allow-bit

add action=add-src-to-address-list address-list=Torrent-Conn address-list-timeout=5m chain=forward comment="Block p2p" log-prefix=torr-conn p2p=all-p2p src-address=192.168.2.0/24 \
    src-address-list=!allow-bit


/ip firewall filter
add action=drop chain=forward dst-port=!0-1024,3389,5222,5800,5900,8291,14147,59905 protocol=tcp \
    src-address-list=Torrent-Conn
add action=drop chain=forward dst-port=!0-1024,3389,5222,5800,5900,8291,14147,59905 protocol=udp \
    src-address-list=Torrent-Conn
add action=drop chain=forward out-interface=192.168.2.0/24 content="\r\nContent-Type: application/x-bittorrent" protocol=tcp src-port=80 comment=".torrent \r\nContent-Type...."

#ตรงสีแดงให้เปลี่ยน IP Address เป็นวง Network ที่ใช้ครับ

/ip firewall mangle
add action=mark-packet chain=postrouting comment="p2p download" disabled=no layer7-protocol=layer7-bittorrent-exp new-packet-mark="p2p download" passthrough=no

/ip firewall filter
add action=drop chain=forward disabled=no p2p=all-p2p
add action=drop chain=forward in-interface=ether1 comment="torrent dht out magnet" content=d1:ad2:ad20 disabled=no dst-port=1025-65535 packet-size=95-190 protocol=udp
add action=drop chain=forward in-interface=ether1 comment=info_hash content=info_hash disabled=no dst-port=2170,80 protocol=tcp
add action=drop chain=forward out-interface=bridge1 content="\r\nContent-Type: application/x-bittorrent" protocol=tcp src-port=80 comment=".torrent \r\nContent-Type...."

#สีน้ำเงินเป็น Interface Name ที่ออก Internet
#สีเขียวเป็น Interface Name ฝั่ง Lan ครับ
#เวลา Run Script จะขึ้น Obsolete เดี๋ยวผมหาข้อมูลเพิ่มเติมอีกทีครับ

สวัสดีครับ

หลังจากลองหาใน mikrotik.com มาพักใหญ่ๆ เจอจนได้ครับ การ Block Bittorrent แบบได้ผล 100% (ณ.ตอนทดสอบนะครับ)


จะเป็น Script ตามด้านล่างครับ

/ip firewall layer7-protocol
add comment="" name=bittorrent regexp="^(\\x13bittorrent protocol|azver\\x01\$\
    |get /scrape\\\?info_hash=get /announce\\\?info_hash=|get /client/bitcomet\
    /|GET /data\\\?fid=)|d1:ad2:id20:|\\x08'7P\\)[RP]"
add comment="" name=bit regexp=\
    "^(\\x13bittorrent protocol|azver\\x01\$|get /scrape\\\?info_hash=)"


/ip firewall filter
add action=add-dst-to-address-list address-list=bit_addr \
    address-list-timeout=1d chain=forward comment="block bit" disabled=no \
    dst-address=!192.168.110.0/24 p2p=all-p2p
add action=add-dst-to-address-list address-list=bit_addr \
    address-list-timeout=1d chain=forward comment="block bit" disabled=no \
    dst-address=!192.168.110.0/24 layer7-protocol=bittorrent
add action=add-dst-to-address-list address-list=bit_addr \
    address-list-timeout=1d chain=forward comment="block bit" disabled=no \
    dst-address=!192.168.110.0/24 layer7-protocol=bit
add action=drop chain=forward comment="block bit" disabled=no \
    dst-address-list=bit_addr
add action=drop chain=forward comment="block bit" disabled=no \
    src-address-list=bit_addr
add action=drop chain=input comment="block bit" disabled=no src-address-list=\
    bit_addr
add action=drop chain=input comment="block bit" disabled=no dst-address-list=\
    bit_addr



1. แก้ไข Script ค่า IP ที่เป็นสีแดง ตามวง Network ที่เราเชื่อมต่ออยู่ครับ เช่นถ้า RouterBoard เป็น IP: 192.168.1.1 SubnetMask เป็น 255.255.255.0 ก็เปลี่ยนเป็น 192.168.1.0/24 เสร็จแล้ว Copy (Ctrl + C)ไว้ครับ


2. เปิด Winbox เข้า Menu New Terminal ให้ Click Mouse ขวาที่ Command Line เลือก Paste และกด Enter ซัก 1 ที






3. ตรวจสอบที่ Firewall จะต้องมีเหมือนตามรูปครับ







ทดสอบ

ผมลอง Download Bit ก่อนทำการ Run Script จะ Download ได้อย่างปกติ



หลังจาก Run Script เรียบร้อยแล้ว จะต้องไม่สามารถ Download ได้ครับ





ทีนี้ในกรณีที่ต้องการกลับมา Download Bittorrent ได้เหมือนเดิม

1. เข้า Menu IP --> Firewall --> Filter Rules ให้ Disable รายการที่เป็น block bit ครับ ด้วยการกดปุ่ม [ x ]




2. Menu IP --> Firewall --> Address List เลือกรายการทั้งหมด กด Ctrl + A ได้เลยครับ แล้ว Click [ - ]





เรียบร้อยครับ  ;D ;D ;D
« แก้ไขครั้งสุดท้าย: วันที่ 15 มิถุนายน 2017, 17:48:52 โดย yod »

wong62

  • VIP
  • Full Member
  • *****
  • กระทู้: 130
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #1 เมื่อ: วันที่ 17 มิถุนายน 2011, 21:20:09 »
มีเน็ต 3 เส้น ต้องการให้ออกเฉพาะเส้นที่ 3 ต้องทำยังไงครับ :o

yod

  • บุคคลทั่วไป
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #2 เมื่อ: วันที่ 18 มิถุนายน 2011, 14:52:30 »

เดี๋ยวขอหาข้อมูลก่อนครับ

ualone

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 14
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #3 เมื่อ: วันที่ 7 ธันวาคม 2011, 16:30:38 »
ลองดูแล้วใช้ได้ โอเคเลยครับ

ขอบคุณครับ

wong62

  • VIP
  • Full Member
  • *****
  • กระทู้: 130
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #4 เมื่อ: วันที่ 8 ธันวาคม 2011, 23:11:28 »
อันนี้เจ๋งสุดๆทีเคยลองมาแล้วครับ เล่นเอาขาโหลดปิดคอมพ์หนีไปเลย ;D ;D ;D

ualone

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 14
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #5 เมื่อ: วันที่ 14 มีนาคม 2012, 14:41:09 »
ขอบคุณครับ ลองแล้ว โอเคเลย

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1844
    • Sysnet Center
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #6 เมื่อ: วันที่ 14 มีนาคม 2012, 17:00:45 »
;D ;D ถ้ายังไงรบกวนลองกับโปรแกรม uTorrent และ BitComet ให้ผมด้วยได้มั้ยครับ ช่วงนี้ผมไม่ได้ load bit เลย ;D ;D

ualone

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 14
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #7 เมื่อ: วันที่ 14 มีนาคม 2012, 18:17:05 »
ผมลองครับ Utorrent ครับ  ;D

สอบถามนิดนะครับ พวกโปรแกรม ที่ทำงานแบบ P2P นี้ตัวอื่นๆ (รู้สึกว่าจะมีโปรแกรมจำพวกนี้เยอะ ซึ่งผมก็ยังไม่รู้ว่ามีตัวไหนบ้างนะครับ)

สคลิปนี้เอาอยู่ใช่ป่าวครับ เพราะผมก็ลองกับพวก โปรแกรมโหลดบิท อย่าวเดียว อย่างพวก utorrent bittorrent

toong

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 1
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #8 เมื่อ: วันที่ 3 เมษายน 2012, 14:35:07 »
ขอบคุณครับ

SUTHEP

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 2
    • อีเมล์
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #9 เมื่อ: วันที่ 16 เมษายน 2012, 11:43:07 »
ขอบคุณครับ....

 RB751 ที่ซื้อมามัน OK เลย

jonglak

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 12
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #10 เมื่อ: วันที่ 10 มิถุนายน 2012, 18:05:46 »
RB1100Ah ใช้คำสั่งแบบนี้ไม่ได้ครับต้องใช้แบบไหนหรอครับ ???

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1844
    • Sysnet Center
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #11 เมื่อ: วันที่ 11 มิถุนายน 2012, 05:31:00 »

ได้ปกตินะครับ เพราะ package pcc ไม่ได้ต่างอะไรจากตัวธรรมดาครับ

ลองดูว่ามีการทำ firewall ตัวอื่นๆไว้แล้วมันขัดกันเองหรือเปล่าครับ เพราะกฏของ firewall ถ้ามันตรงกับตัวแรก มันจะไม่ทำตัวถัดไปแล้วครับ

GETTO

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 13
    • อีเมล์
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #12 เมื่อ: วันที่ 16 มิถุนายน 2012, 19:08:20 »
450G ใช้งานได้ปกติครับ  ขอบคุณครับพี่ยอด

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1844
    • Sysnet Center
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #13 เมื่อ: วันที่ 17 มิถุนายน 2012, 05:17:11 »
450G ใช้งานได้ปกติครับ  ขอบคุณครับพี่ยอด[/size]

ต้องลองเล่นบ่อยๆครับ มันทำอะไรได้เยอะมากจริงๆ เวลา config กดปุ่ม safemode ไว้ด้วยก็ดีครับ ถ้า set อะไรผิด login เข้าไม่ได้ แค่ปิดเปิดเครื่องมันก็จะกลับค่าเดิมก่อนที่จะกดปุ่ม

pjk

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 4
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #14 เมื่อ: วันที่ 5 มีนาคม 2013, 13:47:06 »
ขอบคุณสำหรับสคริปต์ที่ใช้งานได้จริงครับ, ผมลองหาสคริปต์อื่นที่ใช้ reg express ใน L7 แต่พบว่าไม่สามารถ Block bit ได้ แต่สคริปต์นี้ทำงานแตกต่างคือใส่ dst address ลงใน list ก่อนแล้วค่อย block ip ใน address list..

มีข้อสงสัยรบกวนสอบถามดังนี้ครับ ผมลองแก้ไขว่า แทนที่จะใช้ "add dst to address list" ผมเปลี่ยนเป็น "drop" เลย ปรากฏว่าไม่สามารถ block bit ได้ เลยงงๆ ครับว่าทำไมเราต้องใส่ลงใน dst address ก่อน แล้วค่อย block ip เลย แทนที่จะ drop ไปตั้งแต่เงื่อนไขตรงกับ reg express ครับ

ขอบคุณครับ :)

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1844
    • Sysnet Center
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #15 เมื่อ: วันที่ 5 มีนาคม 2013, 13:57:33 »

จะเป็นการ add peer เข้าไปด้วยครับ แล้วก้ block ไม่ให้ติดต่อกับ peer ได้

pjk

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 4
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #16 เมื่อ: วันที่ 6 มีนาคม 2013, 10:19:10 »
ขอบคุณครับ  :)

ronnakorn

  • Mikrotik
  • Newbie
  • *****
  • กระทู้: 6
    • อีเมล์
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #17 เมื่อ: วันที่ 6 ตุลาคม 2013, 14:26:54 »
450G ของผมทำแล้วทำไมยังโหลดได้ครับผม
รบกวนดูให้หน่อยครับ

Mr.Zenith

  • VIP
  • Full Member
  • *****
  • กระทู้: 172
  • Central Radius Expert
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #18 เมื่อ: วันที่ 6 ตุลาคม 2013, 18:55:19 »
ถ้าไปเซ็ตให้ uTorrent มัน Encrypted ไว้ ยังไงก็โหลดได้ทุกกรณีครับ
เพราะ Mikrotik มันไม่สามารถวิเคราะได้ลึกถึงระดับ Header ของ Packet ครับ อุปกรณ์ราคาเท่านี้ ก็ได้เท่านี้ล่ะครับ

yod

  • Administrator
  • Hero Member
  • *****
  • กระทู้: 1844
    • Sysnet Center
Re: Block Bittorrent ด้วย Mikrotik Router Board
« ตอบกลับ #19 เมื่อ: วันที่ 8 ตุลาคม 2013, 12:51:43 »
http://www.sysnetcenter.com/board/upload/files/images/mu8km9-wireless-87c741.jpg[/img]


ให้ตัดการเชื่อมต่อของเครื่องลูกข่ายออกให้หมดก่อนครับ


Share via facebook

xx
ถามข้อสงสัยครับ Block Bittorrent ด้วย Mikrotik Router Board

เริ่มโดย llwswss เมื่อ อุปกรณ์ Mikrotik Router

5 ตอบ
3648 อ่าน
กระทู้ล่าสุด วันที่ 1 กันยายน 2012, 06:33:29
โดย yod
xx
การ Block Facebook และ UnBlock บางเครื่อง ด้วย Router Board

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

5 ตอบ
23343 อ่าน
กระทู้ล่าสุด วันที่ 5 มิถุนายน 2017, 16:58:26
โดย kaewman.s
xx
Block Bittorrent ด้วย Linksys WRT54GL Firmware DD-WRT V24

เริ่มโดย yod เมื่อ อุปกรณ์ Cisco, Linksys By Cisco

3 ตอบ
21778 อ่าน
กระทู้ล่าสุด วันที่ 12 ธันวาคม 2012, 04:20:34
โดย surin-club
xx
ช่วยหน่อย ตั้งค่า Mikrotik Block Bittorrent ทำไงครับ

เริ่มโดย Hatiw เมื่อ สอบถามข้อมูลทั่วๆไป ข่าวสารจากร้าน Sysnet Center

0 ตอบ
3048 อ่าน
กระทู้ล่าสุด วันที่ 3 กรกฎาคม 2013, 20:46:41
โดย Hatiw
xx
การ Upgrade RouterOS สำหรับอุปกรณ์ Mikrotik Router Board

เริ่มโดย yod เมื่อ อุปกรณ์ Mikrotik Router

0 ตอบ
16558 อ่าน
กระทู้ล่าสุด วันที่ 30 ตุลาคม 2012, 09:34:27
โดย yod
 


Users found this pages searching for: